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Exercise 1 – Adding Data to a New BASINS Project
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Question addressed in this section:
1) How do I build a new BASINS project?
2) How do I navigate the BASINS 4.0 GIS environment?
3) How do I add land use data?
4) How do I add NHDPlus data?
5) How do I add BASINS census and TIGER line data?
6) How do I add BASINS Digital Elevation Model (DEM) grids?
7) How do I import other shapefiles?
8) How do I download timeseries data for use in modeling?

A. Building a BASINS Project
QUESTION ANSWERED:
1) How do I build a BASINS project?
1.

From the Start menu under Programs, select BASINS and then BASINS 4. The
“Welcome to BASINS 4” window will open.

2.

Click the “Build BASINS Project.” The following window will open.
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Click
(Zoom In tool). Using the “Zoom In” tool, zoom into the area near the
states of Virginia and Maryland.
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4.

Click

5.

Click the Patuxent Watershed (Cataloging Unit number 02060006). Notice that the
description of the selected feature(s) appears in the “Build New BASINS 4 Project”
window.

(Select Feature tool).

Select only
one HUC.

6.

Click BUILD in the “Build New BASINS 4 Project” window.
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7.

Enter “Patuxent.mwprj” as the file name.

8.

Click SAVE. The “Projection Properties” window will open.
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9.

From the “Category” menu, select “UTM – 1983.”

10.

From the “Type” menu, select “Zone 18.”

11.

Click OK. At this point the data will be downloaded, extracted, and projected. Wait
while this process proceeds.
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Click OK. The new BASINS project will open.

B. Navigating the BASINS 4.0 GIS Environment
QUESTION ANSWERED:
2) How do I navigate the BASINS 4.0 GIS environment?
Notice that within the BASINS 4.0 GIS environment there are three distinct panels. The
most prominent one is the map itself. To the left of the map is the legend showing which
layers are currently available and/or displayed on the map. In the bottom left corner is the
preview map providing an image of the map zoomed to the full extent of all layers. The
preview map can be used to orient you within the many map layers.
Notice in the map legend that sets of layers are combined into logical groups. For instance
layers pertaining to hydrology are listed in a group labeled ‘Hydrology.’ Similar groups
exist for Observed Data, Political Boundaries, Point Source Data, Transportation Layers, etc.

1.

The Reach File, V1 layer is currently “on” because the box is checked next to its
name. Click the check box next to Reach File, V1 to turn this layer “off.” Notice that
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when you do so, the blue lines disappear from the map.

2.

Now turn it back “on” by clicking the check box again. Notice that the Reach File,
V1 name in the “Table of Contents” is shaded and surrounded by a box (see figure
below). This means the layer is “active.”

Zooming Tools
BASINS 4.0 has typical GIS tools for zooming in and out.
(Zoom In tool)
(Zoom Out tool)

1.

Click

(Zoom In tool).

2.

Drag a box on the map around the area you would like to zoom to.
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Notice that the map zooms into that area.

3.

Right click on the Cataloging Units Boundary layer and select “Zoom to Layer.”
This will return the map to the full extent of the Cataloging Units Boundary layer.
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Table Editor Tool
BASINS 4.0 has a “Table Editor tool”,
associated with map features.

, that allows you to view and edit the attributes

1.

Make sure the Reach File, V1 layer is “on” and “active.”

2.

(Table Editor tool). The “Attribute Table Editor” will appear. It displays
Click
the attribute table associated with the “active” layer.

3.

Select a cell in the left-most column of the table. The feature corresponding to the
row you selected will be highlighted in yellow on the map.

1-9

BASINS/HSPF Training

4.

Exercises

Close the “Attribute Table Editor” window.

C. Importing Land Use Data
QUESTION ANSWERED:
2) How do I add land use data?
BASINS 4.0 provides access to land use data in 3 forms: GIRAS land use data from the
1970s, and National Land Cover Data (NLCD) for 1992 and 2001. The GIRAS data is in
shapefile format, and the NLCD data is distributed as grids. For this example we will
download and add the GIRAS land use to our project because these files are relatively quick
to download and reproject.
1.

From the File menu, select Download Data.

2.

With the ‘Region to Download’ set to ‘Hydrologic Unit 02060006’, check the box
next to “GIRAS Land Use.”
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3.

Click DOWNLOAD.

4.

Click OK when the data has been downloaded.

Note: The GIRAS Land use data comes in tiles. There are two land use tiles that
contribute to the Patuxent watershed: “l_baltmd.shp” and “l_washdc.shp,”
corresponding to Baltimore, Maryland, and Washington DC, respectively.
We added both of these layers to the Patuxent project.
5.

Scroll down in the “Table of Contents” to Land Use baltmd and Land Use washdc.
Click the ‘+’ next to the layer name to expand the legend for each layer. Your view
should look like the following.
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Note: You probably can not see the outline of your watershed very well. If you
want, you can change the color and/or thickness of the boundary by double
clicking on the Cataloging Unit Boundaries layer and changing the line
thickness.
6.

Turn “off” Land Use baltmd and Land Use washdc.
Note: Often, users may have an alternative land use layer available to them that is
more detailed or recent than the land use layer in the core BASINS data set. A
new land use layer can be imported into a BASINS project using the BASINS
“Add Layer” button. Additionally, the National Land Cover Data (NLCD) for
1992 and 2001 can be downloaded and added to your project by using the
Download Data tool. Once a new land use data set is added, it can be
reclassified using the Reclassify Land Use tool.

D. Importing NHDPlus Data
QUESTION ANSWERED:
4) How do I add NHDPlus data?
The National Hydrography Dataset (NHD) is a more complete hydrography layer than the
Reach File, V1 (RF1) layer in the BASINS core data set. NHDPlus incorporates features of
other national data sets with the NHD, adding additional map layers and additional attributes
to the NHD.
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1.

From the File menu, select Download Data.

2.

Check the box next to “Catchments” and “Hydrography” within the NHDPlus section
of the Data Download tool.

3.

Click DOWNLOAD. When the download has finished, the following window will
appear.

4.

Click OK. Turn off the RF1 layer, and scroll down the table of contents until you see
the NHDPlus Flowlines, Catchments, Area Features, and Waterbody Features in a
group entitled ‘Hydrology-NHDPlus’. You may wish to zoom closer to examine
these new layers.
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Turn “off” the NHDPlus layers, and turn “on” the RF1 layer again.

E. Importing the BASINS Census and TIGER Line Data
QUESTION ANSWERED:
5) How do I add BASINS Census and TIGER line data?
The BASINS Census data includes boundary information and tabular data from the 1990 and
2000 Census, as well as TIGER line data such as detailed roads and railroads.

1.

From the File menu, select Download Data.

2.

Check the box next to “Census.”
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3.

Click DOWNLOAD. When the download has finished, the following window will
appear.

4.

Click OK.

5.

Scroll down in the “Table of Contents” to see the group of “Census” layers.

6.

Scroll up in the “Table of Contents” to see the group of “Transportation” layers.
Notice that the 2002 Tiger Road 02060006 layer was automatically turned “on” when
the BASINS Census data was downloaded.
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7.

Click the ‘+’ next to 2002 Tiger Road 02060006 layer to see the different types of
roads.

8.

Turn “on” the 2000 Census Tract 02060006 boundaries layer.

9.

Zoom in to a portion of the watershed to see the detail of the 2002 Tiger Road
02060006 layer using the zoom

tool.
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Turn “off” 2002 Tiger Road 02060006 and 2000 Census Tract 02060006. Right
click on the Cataloging Unit Boundaries layer and use the “Zoom to Layer” feature
to return to the full extent of the Cataloging Unit.

F. Importing the BASINS Digital Elevation Model (DEM) Grids
QUESTION ANSWERED:
6) How do I add BASINS DEM grids?
A digital elevation model (DEM) is a grid of elevations. Each grid cell contains one
elevation value and the assembly of grid cells represents the topography of a coverage area.
The DEM is useful in topographic relief mapping and watershed delineation. DEMs are
available through BASINS as either shapefiles or GeoTiff grids. Since this data is most
conventionally used in grid format, we will download the grid format DEM.
1.

From the File menu, select Download Data.

2.

Check the box next to “DEM Grid”.
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3.

Click DOWNLOAD. When the download has finished, the following window will
appear.

4.

Click OK. The Digital Elevation Model layer will be added to your “Table of
Contents” under the “Elevation” group.

5.

Turn “on” the Digital Elevation Model layer, and click the ‘+’ next to the layer in the
“Table of Contents.”
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6.

Zoom into a section of the Cataloging Unit.

7.

Click
(Identify Tool) and then click around to view some elevation values in the
watershed.

8.

Turn “off” the grid layer Digital Elevation Model. Right click on the Cataloging Unit
Boundaries layer and use the “Zoom to Layer” feature to return to the full extent of
the Cataloging Unit.

G. Adding Additional Shapefiles to the Map
QUESTION ANSWERED:
7) How do I import other shapefiles?
Users will often have additional GIS layers that would be useful to display along with the
BASINS layers (e.g., a study area boundary). Users can import their own shapefile layers
using the BASINS “Add Layer” tool.
1.

Turn “on” the NHDPlus Flowline Features layer.

2.

From the View menu, select Add Layer, or click the

3.

Navigate to c:\basins\Predefined Delineations. Select “w_branch.shp” and click
OPEN.
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4.

The layer W_branch will be added to the “Table of Contents” and turned “on.” This
layer appears filled in. We want to change it so that only the outline is visible.

5.

Double click W_branch in the “Table of Contents.” The “Legend Editor” will
appear.
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6.

In the “Legend Editor,” change the “OutlineColor” to “Red” and “ShowFill” to
“False.”

7.

Close the “Legend Editor.” The layer will appear as shown below.

8.

From the File menu select Save.

H. Adding Timeseries Data to our Project
QUESTION ANSWERED:
8) How do I download timeseries data for use in modeling?
When setting up a new project you will want to download the meteorological timeseries data
necessary for modeling. This section focuses on using the “Data Download” tool to retrieve
meteorological data and create a meteorological WDM file (which contains the required
weather data for HSPF) for our current project. Later in the training, the contents and uses of
WDM files will be discussed.
Prior to the October 2007 update to BASINS 4.0, BASINS meteorological WDM files were
distributed by state. These files were very limited in scope, with an average of only 10
stations per state, and the data were only provided through the year 1995.
With the October 2007 (or later) update to BASINS 4.0 installed, BASINS provides more
comprehensive and recent meteorological data for modeling. The updated database contains
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data at over 16,000 stations, although not all stations are still active and most of them contain
only a subset of all the meteorological constituents used in BASINS. For those stations that
are current, data have been updated through the year 2006.
The following steps show how to download the updated BASINS Meteorological stations
and corresponding time series data.
1.

From the File menu, select Download Data.

2.

Check the box next to “Met Stations”.

3.

Click DOWNLOAD. When the download has finished, the following window will
appear.

4.

Click OK.

5.

The Weather Station Sites 2006 layer will be added to your “Table of Contents”
under the “Observed Data Stations” group.
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The symbols on the map indicate the locations of the new met data and the types of data
available at each location. The location of each station is represented by a fuchsia box
marked with the letter ‘M’, surrounded by icons representing the meteorological constituents
available at that location.
The icon below shows a station with all of the possible meteorological constituents available.

Where:
•
•
•
•
•
•
•

Blue arrow containing a ‘P’ and pointing down = precipitation
Blue arrow containing an ‘E’ and pointing up = potential evapotranspiration
White arrow containing a ‘W’ and pointing sideways = wind speed
Grey cloud containing a ‘C’ = cloud cover
Yellow sun containing an ‘S’ = solar radiation
Red (thermometer) icon = air temperature
Cyan water drop containing a ‘D’ = dewpoint temperature
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Now that we have the updated BASINS Meteorological stations, we will proceed to
download the corresponding time series data.
6.

Using the Selection Tool
, drag a box across entire map view, selecting all of the
met stations shown on the map. The resulting map should look like the following.
Note that the selected stations will be shown with a green ‘M’.

7.

From the File menu, select Download Data.

8.

Check the box next to “Met Data”.

9.

Click DOWNLOAD. You will be prompted with options for storing the downloaded
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met data. Leave this form as it defaults to add the data to a new WDM file.

10.

Click OK. While the data is downloading, you will see progress messages.

11.

The following window will appear.

12.

Click OK. The following ‘Data Sources’ window will appear showing us the
timeseries files available within this project. The ‘met.wdm’ file shown in this
window was just added during the previous download steps. We will discuss this
window more in a later exercise.

13.

Close the ‘Data Sources’ window by clicking the ‘X’ in the top right corner.

The resulting WDM file containing the actual time-series data is named met.wdm and is
stored in the BASINS project directory (e.g., \BASINS\Data\02060006\met). We will
discuss details of the BASINS met WDM files in another exercise, and as we set up the
watershed model.
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14.

Turn “off” the Weather Station Sites 2006 layer.

15.

From the File menu select Save to save the project.

1-26

